编译mcrypt遇到的错误


  1. *** 'libmcrypt-config --version' returned 2.4.0, but LIBMCRYPT (2.5.8)   

  2. *** was found! If libmcrypt-config was correct, then it is best   

  3. *** to remove the old version of LIBMCRYPT. You may also be able to fix the error   

  4. *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing   

  5. *** /etc/ld.so.conf. Make sure you have run ldconfig if that is   

  6. *** required on your system.   

  7. *** If libmcrypt-config was wrong, set the environment variable LIBMCRYPT_CONFIG   

  8. *** to point to the correct copy of libmcrypt-config, and remove the file config.cache   

  9. *** before re-running configure   

  10. configure: error: *** libmcrypt was not found  

问题原因是path,他在path目录里没找到,
解决方法:方法是ln -s /usr/local/bin/libmcrypt-config /usr/bin/libmcrypt-config

You May Also Like

About the Author: admin

发表评论

邮箱地址不会被公开。 必填项已用*标注